• Leonard Smith Discount Error
    We are aware of the Leonard Smith Event discount not working properly for players. We will reactivate the event once we correct the issue blocking the 15% Discount.

This application is not compatible with your device

Meria

Approved user
LV
0
 
Joined
Jul 21, 2016
Messages
5
[RESOLVED]

Hello,

I play Dominations on my Samsung S4 running Android 4.4.4 and since this weekend update I can not update the game because my device is no longer compliant for the game. Hence, I can no longer play the game.

Are the requirement to play the game changed with this recent 8.1 version of the game ? Is it an expected behavior ? I did not see any information in the patch readme. If not, then it is a bug and I'd like to have this fixed asap because I litterally cannot play the game anymore.

Thank you
 
Last edited:

sponge

Approved user
LV
0
 
Joined
Jun 4, 2015
Messages
494
Android 4.4.4? Current version is 10 so your version is ancient. I know it came out in 2013, but by today's standards it's Stone Age. Do you run Windows 98, Mac OS 9, or some Linux with kernel 2.x on your desktop and expect software developers to maintain their software to run on ancient systems?

Bottom line, upgrade your OS. And if that means upgrading your phone, well, welcome to the wonderful world of 3rd party (non-Google) Android devices.
 
Last edited:

Meria

Approved user
LV
0
 
Joined
Jul 21, 2016
Messages
5
Hi Sponge,

I know wht you mean but that's something that was supported until last week. They should communicate clearly that 4.4.4 is no longer supported. In software industry you write black on white the compatibility requirements.If the requirements change, they should notice the users about it.

I am not here to debate on the rest of your message and prefer to stick to my topic :

Are the requirement to play the game changed with this recent 8.1 version of the game ? Is it an expected behavior ?
 

Meria

Approved user
LV
0
 
Joined
Jul 21, 2016
Messages
5
Close topic, the issue lies with the internet browser used (internet web connexion requested by the game) to connect to the play store causing this incompatibility message. It has been workarounded by launching directly the play store.
 
Top