HUGE BUG - Losing more resources from your defenses than your enemy took!!!

Hyperion

Approved user
Joined
Dec 26, 2014
Messages
56
Here is a massive bug, that has probably been affecting people who are completely unaware.
I assume this bug has been going on for a long while, as it is incredibly easy to overlook.


So I was just attacked today, here is what my defense log says I lost;
http://imgur.com/oMVTJNl,EDOe3GK,IsMdO2S#0

I double check the ammount lost with my resource tally (I had only stopped playing 20 minutes prior, so I knew how much gold I had.
The defense log said I lost 91k gold, and my resources also appear to have lost 91k gold.
I thought I would just take a look at the raid replay just to see how he got all my gold resources...

Here is the start of his attack, hmm that's odd 90,648 gold available, yet he stole 91,031 gold.
http://imgur.com/oMVTJNl,EDOe3GK,IsMdO2S#1


It gets better (worse)...



Looking at the end of his attack, he stops way short of attacking my second gold storage (all his troops are defeated).
He manages to take 59,793 gold on the final defeat screen, which is accurate, as he had not destroyed all my gold storages to get the full amount.
http://imgur.com/oMVTJNl,EDOe3GK,IsMdO2S#2



So why is the full lost gold amount being subtracted when the replay clearly shows he only stole 59,793?
Look at the food resources taken, these are horrible wrong too.

I can only imagine this is happening ALL THE TIME, since this is the first time I have checked this.
 
Last edited:

Hyperion

Approved user
Joined
Dec 26, 2014
Messages
56
Ok boys and girls, i'm afraid this gets EVEN WORSE...

I just replayed the replay for about the 10th time. Just to see if there was any way to give further information on this game-breaking bug.

Guess what? The same defense replay is COMPLETELY different from the previous times I watched them. THE TROOPS EVEN MOVE AND ATTACK IN A DIFFERENT DIRECTION. But it is the same defense replay!

Take a look at the end-battle screen this time...

http://imgur.com/zMwJs0T


Even less gold was taken in this replay... and different trade resources taken??? (I was not keeping track of my resources so I'm not sure which ones I actually lost)
What is going on here???
 

Whatwhat

Approved user
Joined
Jan 11, 2015
Messages
419
I noticed the resource bug you have mentioned. Resources that are shown to be available when raiding are often less than what I get. And I'm not could ting the bonus. Also when I check my log of how much they have stolen from me it is often less than what their victory record shows.
 

JeromeTT

Approved user
Joined
Jan 5, 2015
Messages
65
Ok boys and girls, i'm afraid this gets EVEN WORSE...

I just replayed the replay for about the 10th time. Just to see if there was any way to give further information on this game-breaking bug.

Guess what? The same defense replay is COMPLETELY different from the previous times I watched them. THE TROOPS EVEN MOVE AND ATTACK IN A DIFFERENT DIRECTION. But it is the same defense replay!

Take a look at the end-battle screen this time...

The answer is actually quite simple once you understand.

When you attack someone, it doesn't record the actual replay of the attack(if it did it would take up a heap load of server space), the servers actually record the commands every time you place a troop, use tactics, etc. But once in a while their is a bug that causes the replay to show differently.

So basically, the defensive log itself is the most accurate, the replay itself may be bugged.

To avoid confusion, the DEVS could:
1) message everyone in game
2)remove the replays entirely until they are stable
3) post a sticky on the bugs catagories on the forum
 
G

Guest

Guest
Hey, all -- there were issues concerning the information shown in replays and what was actually displaying in battle reports. JeromeTT best explained what was actually happening, but they released a fix for this in the latest update. Could you or anyone else please let us know if you're noticing that this is still an issue, thanks!
 

herogjan

Approved user
Joined
Jan 8, 2015
Messages
10
Hey, all -- there were issues concerning the information shown in replays and what was actually displaying in battle reports. JeromeTT best explained what was actually happening, but they released a fix for this in the latest update. Could you or anyone else please let us know if you're noticing that this is still an issue, thanks!
I've still this bug, 3 attacks from which 2 took double amount of loot, the other one took less
 

Attachments

  • Screenshot_2015-02-17-00-48-34.png
    Screenshot_2015-02-17-00-48-34.png
    86.5 KB · Views: 48
  • Screenshot_2015-02-17-00-44-20.png
    Screenshot_2015-02-17-00-44-20.png
    94.9 KB · Views: 43

herogjan

Approved user
Joined
Jan 8, 2015
Messages
10

Attachments

  • Screenshot_2015-02-17-00-44-04.jpg
    Screenshot_2015-02-17-00-44-04.jpg
    223.6 KB · Views: 45
  • Screenshot_2015-02-17-00-45-44.jpg
    Screenshot_2015-02-17-00-45-44.jpg
    222.2 KB · Views: 52
  • Screenshot_2015-02-17-00-48-03.jpg
    Screenshot_2015-02-17-00-48-03.jpg
    228.5 KB · Views: 44
G

Guest

Guest
Hey herogjan -- thanks for providing these screenshots! I'll share this with the team so that they can continue to look into this.
 
Top